Microsoft 365 Issues
Incident Report for MalgraBooks
Postmortem

Response from Microsoft

User impact: Users couldn't freely edit unlocked cells in protected Excel files opened in Excel for the web.

More info: Some users modifying unlocked cells in protected Excel for the web files would receive a prompt that the cells were protected. Affected users could have bypassed the problem by opening files in the Excel desktop app, if accessible.

Final status: We've disabled the offending changes and confirmed through an additional period of monitoring that the issue is resolved throughout the affected environment. Users encountering persistent impact may need to refresh their Excel for the web session to see remediation.

Scope of impact: Some users are impacted when attempting to edit unlocked cells in protected files through Excel for the web.

Root cause: Two recent changes to introduce a new feature that was intended to improve the content latency in Excel for the web resulted in impact.

Next steps:

  • We're reviewing our update testing and validation methods to better identify the potential for issues such as this prior to deployment to prevent similar impact in the future.
Posted Dec 21, 2023 - 12:54 GMT

Resolved
Microsoft are currently rolling out a fix which should be active from 18:00 - apologies for any inconvenience caused.
Posted Dec 20, 2023 - 14:33 GMT
Update
If you need access to your cloud spreadsheet during this time, please contact our team for assistance.
Posted Dec 20, 2023 - 12:45 GMT
Investigating
We're aware of an issue with Microsoft 365 which is affecting Cloud Spreadsheets.
Our team are currently working with our contacts at Microsoft to resolve this issue as quickly as possible.
Posted Dec 20, 2023 - 12:44 GMT
This incident affected: MalgraBooks Services (Cloud Spreadsheets System) and Third Party Services (Microsoft 365).