Tax Knowledgebase Unavailable
Incident Report for MalgraBooks
Resolved
This issue has been resolved.
Posted Nov 29, 2022 - 10:55 GMT
Identified
We're aware of issues with the tax knowledgebase website which doesn't appear to load in some browsers, mainly Edge.

In the meantime, please use an alternative browser, such as Google Chrome, Apple Safari or Mozilla Firefox.

Our team are checking for further details and will update shortly.

We apologise for any inconvenience caused at this time
Posted Nov 29, 2022 - 10:44 GMT
This incident affected: MalgraBooks Services (Tax Guide Wesbite).