Website running slow
Incident Report for MalgraBooks
Resolved
This incident has been resolved.
Posted Jan 19, 2021 - 17:53 GMT
Identified
We're aware that the malgra.net website is currently running slowly - this is due to increased demand, we're currently looking into expanding our server resources
Posted Jan 19, 2021 - 17:47 GMT
This incident affected: MalgraBooks Services (Tax Guide Wesbite).