Duplicate Emails
Incident Report for MalgraBooks
Resolved
All fixed. Our system issue has been resolved, thank you for your patience.
Posted Dec 06, 2023 - 14:49 GMT
Identified
We've found the issue with BCC emails duplicating. We're on it.
Posted Dec 06, 2023 - 14:09 GMT
Investigating
We're aware that our email service appears to be sending duplicate emails at the moment (better than not receiving any, we guess) - but this is obviously a fault. We're currently looking into the issue.
Posted Dec 06, 2023 - 14:08 GMT
This incident affected: MalgraBooks Services (MalgraBooks Websites).