eLearning Unavailable
Incident Report for MalgraBooks
Resolved
The temporary eLearning platform is now live: https://account.malgra.net/courses
Posted Jan 15, 2021 - 18:14 GMT
Identified
We're sorry, but our eLearning Portal is currently unavailable.

The fault has been identified and is being looked into.

ETA: Monday
Posted Jan 15, 2021 - 17:46 GMT